summaryrefslogtreecommitdiff
path: root/src/linux/Makefile.am
diff options
context:
space:
mode:
authorRichard Hughes <richard@hughsie.com>2013-01-09 10:28:58 +0000
committerRichard Hughes <richard@hughsie.com>2013-01-10 12:08:46 +0000
commitb1f12feb1fd4535255f04c91bef90ae11ce57311 (patch)
tree2d99025ec329b8e295a8c42c9ab15d54f28090bf /src/linux/Makefile.am
parentb188a49a9c9a2521429552c644151ae4a3acdfc6 (diff)
downloadupower-b1f12feb1fd4535255f04c91bef90ae11ce57311.tar.gz
Factor out the Logitech Unifying support to support other devices
Diffstat (limited to 'src/linux/Makefile.am')
-rw-r--r--src/linux/Makefile.am18
1 files changed, 16 insertions, 2 deletions
diff --git a/src/linux/Makefile.am b/src/linux/Makefile.am
index 66ad389..4bb64bc 100644
--- a/src/linux/Makefile.am
+++ b/src/linux/Makefile.am
@@ -30,8 +30,8 @@ libupshared_la_SOURCES = \
up-device-supply.h \
up-device-csr.c \
up-device-csr.h \
- up-device-lg-unifying.c \
- up-device-lg-unifying.h \
+ up-device-unifying.c \
+ up-device-unifying.h \
up-device-hid.c \
up-device-hid.h \
up-device-wup.c \
@@ -42,11 +42,25 @@ libupshared_la_SOURCES = \
up-dock.h \
up-backend.c \
up-native.c \
+ hidpp-device.c \
+ hidpp-device.h \
sysfs-utils.c \
sysfs-utils.h \
$(idevice_files) \
$(BUILT_SOURCES)
+noinst_PROGRAMS = \
+ hidpp-test
+hidpp_test_SOURCES = \
+ hidpp-device.c \
+ hidpp-device.h \
+ hidpp-test.c
+hidpp_test_LDADD = \
+ -lm \
+ $(GLIB_LIBS) \
+ $(GIO_LIBS)
+hidpp_test_CFLAGS = $(AM_CFLAGS) $(WARNINGFLAGS_C)
+
EXTRA_DIST = $(libupshared_la_SOURCES) \
integration-test