summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorJussi Kivilinna <jussi.kivilinna@iki.fi>2013-10-22 17:07:53 +0300
committerJussi Kivilinna <jussi.kivilinna@iki.fi>2013-10-22 19:53:29 +0300
commitc7efaa5fe0ee92e321a7b49d56752cc12eb75fe0 (patch)
treec090454520de01a26a0357dc257cede6639674c3 /configure.ac
parent335d9bf7b035815750b63a3a8334d6ce44dc4449 (diff)
downloadlibgcrypt-c7efaa5fe0ee92e321a7b49d56752cc12eb75fe0.tar.gz
serpent-amd64: do not use GAS macros
* cipher/serpent-avx2-amd64.S: Remove use of GAS macros. * cipher/serpent-sse2-amd64.S: Ditto. * configure.ac [HAVE_COMPATIBLE_GCC_AMD64_PLATFORM_AS]: Do not check for GAS macros. -- This way we have better portability; for example, when compiling with clang on x86-64, the assembly implementations are now enabled and working. Signed-off-by: Jussi Kivilinna <jussi.kivilinna@iki.fi>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac7
1 files changed, 1 insertions, 6 deletions
diff --git a/configure.ac b/configure.ac
index 1460dfdf..8fb14e27 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1034,17 +1034,12 @@ if test $amd64_as_feature_detection = yes; then
[gcry_cv_gcc_amd64_platform_as_ok=no
AC_COMPILE_IFELSE([AC_LANG_SOURCE(
[[__asm__(
- /* Test if '.set' is supported by underlying assembler. */
- ".set a0, %rax\n\t"
- ".set b0, %rdx\n\t"
- "asmfunc:\n\t"
- "movq a0, b0;\n\t" /* Fails here if .set ignored by as. */
-
/* Test if '.type' and '.size' are supported. */
/* These work only on ELF targets. */
/* TODO: add COFF (mingw64, cygwin64) support to assembly
* implementations. Mingw64/cygwin64 also require additional
* work because they use different calling convention. */
+ "asmfunc:\n\t"
".size asmfunc,.-asmfunc;\n\t"
".type asmfunc,@function;\n\t"
);]])],