summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac7
1 files changed, 1 insertions, 6 deletions
diff --git a/configure.ac b/configure.ac
index 1460dfdf..8fb14e27 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1034,17 +1034,12 @@ if test $amd64_as_feature_detection = yes; then
[gcry_cv_gcc_amd64_platform_as_ok=no
AC_COMPILE_IFELSE([AC_LANG_SOURCE(
[[__asm__(
- /* Test if '.set' is supported by underlying assembler. */
- ".set a0, %rax\n\t"
- ".set b0, %rdx\n\t"
- "asmfunc:\n\t"
- "movq a0, b0;\n\t" /* Fails here if .set ignored by as. */
-
/* Test if '.type' and '.size' are supported. */
/* These work only on ELF targets. */
/* TODO: add COFF (mingw64, cygwin64) support to assembly
* implementations. Mingw64/cygwin64 also require additional
* work because they use different calling convention. */
+ "asmfunc:\n\t"
".size asmfunc,.-asmfunc;\n\t"
".type asmfunc,@function;\n\t"
);]])],