summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorJoão Valverde <joao.valverde@tecnico.ulisboa.pt>2016-05-22 04:56:48 +0100
committerJoão Valverde <j@v6e.pt>2016-05-22 04:56:34 +0000
commit7a23f422da609a1f291ae9e57d1e53a3b764b9fb (patch)
treeaab5461fe986ef5511c6f947c5859f6c334b18d7 /CMakeLists.txt
parent20c284c96bdc2aa1fdfebc76246cf78d8480f813 (diff)
downloadwireshark-7a23f422da609a1f291ae9e57d1e53a3b764b9fb.tar.gz
Make -Wunused-const-variable a C only warning
Change-Id: If93de2c371f36fa0447fb8215337f0c115d74bbb Reviewed-on: https://code.wireshark.org/review/15524 Reviewed-by: João Valverde <j@v6e.pt>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 65419b7954..2532503016 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -366,7 +366,6 @@ else()
-Wno-overlength-strings
-Wno-long-long
-Wheader-guard
- -Wunused-const-variable
)
set(WIRESHARK_C_ONLY_FLAGS
@@ -379,6 +378,7 @@ else()
-Wstrict-prototypes
-Wlogical-op
-Wjump-misses-init
+ -Wunused-const-variable
# The Qt headers generate a ton of shortening errors on 64-bit systems
# so only enable this for C for now.
-Wshorten-64-to-32