summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorGuy Harris <guy@alum.mit.edu>2013-06-27 10:35:06 +0000
committerGuy Harris <guy@alum.mit.edu>2013-06-27 10:35:06 +0000
commitb450609a5561db9ddfc23b41c742979f5c4b3a32 (patch)
treef51bb7f4d9147b20b7ee5fba3783bf588fde6423 /CMakeLists.txt
parentf3f156073b7fed7db2e8a7a7364873675dbfb097 (diff)
downloadwireshark-b450609a5561db9ddfc23b41c742979f5c4b3a32.tar.gz
For now, don't turn on -Wcast-align by default. There are at least some
bugs it points out that probably mean the code won't work on machines that require alignment (e.g., SPARC machines), but we'll turn it on once we fix them. (clang is fussier than GCC about this.) svn path=/trunk/; revision=50187
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 46826ba11e..2f023677e4 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -124,7 +124,6 @@ set(WIRESHARK_C_FLAGS
-Wendif-labels
-Wpointer-arith
-Warray-bounds
- -Wcast-align
-Wformat-security
-Wshorten-64-to-32
-Wvla
@@ -161,6 +160,7 @@ set(WIRESHARK_EXTRA_C_FLAGS
-fstrict-overflow -Wstrict-overflow=4
-Wunreachable-code
-Wunsafe-loop-optimizations
+ -Wcast-align
-Wcast-qual
-Wformat-security
-Wredundant-decls