summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorAlexis La Goutte <alexis.lagoutte@gmail.com>2017-03-06 21:22:39 +0100
committerMichael Mann <mmann78@netscape.net>2017-04-12 11:28:16 +0000
commitc6fb9ee21495a06ece8681e81872dd23d0d4be85 (patch)
tree817358f3e7add3de1b055b0b36d97a732fd79335 /CMakeLists.txt
parent5be11a5984c32e592e773c3049342861d4f30db1 (diff)
downloadwireshark-c6fb9ee21495a06ece8681e81872dd23d0d4be85.tar.gz
Add -Wduplicated-branches to extra warnings
Change-Id: I11d60b4405f4fde039affcdeebb13a3ceb2aded6 Reviewed-on: https://code.wireshark.org/review/20428 Petri-Dish: Peter Wu <peter@lekensteyn.nl> Tested-by: Petri Dish Buildbot <buildbot-no-reply@wireshark.org> Reviewed-by: Alexis La Goutte <alexis.lagoutte@gmail.com> Reviewed-by: Michael Mann <mmann78@netscape.net>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 992b0cf572..bafcd59750 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -494,6 +494,10 @@ else()
# No longer supported by El Capitan clang on C++
#
-fno-delete-null-pointer-checks
+
+ # Works only with GCC 7
+ -Wduplicated-branches
+
)
set(C_EXTRA_WARN_FLAGS