summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 992b0cf572..bafcd59750 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -494,6 +494,10 @@ else()
# No longer supported by El Capitan clang on C++
#
-fno-delete-null-pointer-checks
+
+ # Works only with GCC 7
+ -Wduplicated-branches
+
)
set(C_EXTRA_WARN_FLAGS