summaryrefslogtreecommitdiff
path: root/tools/lemon/CMakeLists.txt
diff options
context:
space:
mode:
authorJörg Mayer <jmayer@loplof.de>2009-11-07 10:07:00 +0000
committerJörg Mayer <jmayer@loplof.de>2009-11-07 10:07:00 +0000
commit9ee31d1d0e9a10ddb326bc7b23c22dc99bac7f6c (patch)
tree7e19b692aaacf4e9017a30429e79626a73f71a10 /tools/lemon/CMakeLists.txt
parentf6dfb9f323f6253c8c0470b8824d8846f5c578ab (diff)
downloadwireshark-9ee31d1d0e9a10ddb326bc7b23c22dc99bac7f6c.tar.gz
cmake will now honor -Werror if configured (default: on)
svn path=/trunk/; revision=30852
Diffstat (limited to 'tools/lemon/CMakeLists.txt')
-rw-r--r--tools/lemon/CMakeLists.txt12
1 files changed, 12 insertions, 0 deletions
diff --git a/tools/lemon/CMakeLists.txt b/tools/lemon/CMakeLists.txt
index 2b396bcd37..1279110931 100644
--- a/tools/lemon/CMakeLists.txt
+++ b/tools/lemon/CMakeLists.txt
@@ -25,6 +25,18 @@ set(lemon_FILES
lemon.c
)
+set(CLEAN_FILES
+ ${lemon_FILES}
+)
+
+if (WERROR)
+ set_source_files_properties(
+ ${CLEAN_FILES}
+ PROPERTIES
+ COMPILE_FLAGS -Werror
+ )
+endif()
+
set(lemon_LIBS
# Do we need something here on any platform?
)