summaryrefslogtreecommitdiff
path: root/tools/lemon/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tools/lemon/CMakeLists.txt')
-rw-r--r--tools/lemon/CMakeLists.txt12
1 files changed, 12 insertions, 0 deletions
diff --git a/tools/lemon/CMakeLists.txt b/tools/lemon/CMakeLists.txt
index 2b396bcd37..1279110931 100644
--- a/tools/lemon/CMakeLists.txt
+++ b/tools/lemon/CMakeLists.txt
@@ -25,6 +25,18 @@ set(lemon_FILES
lemon.c
)
+set(CLEAN_FILES
+ ${lemon_FILES}
+)
+
+if (WERROR)
+ set_source_files_properties(
+ ${CLEAN_FILES}
+ PROPERTIES
+ COMPILE_FLAGS -Werror
+ )
+endif()
+
set(lemon_LIBS
# Do we need something here on any platform?
)